[Gsmmap] L1 - loads correctly? (corrected)

Dave Schmidt dvsm89 at gmx.com
Thu Jan 12 11:21:01 CET 2012


++ Dear list, please feel free to ban me for not being able to use the email client :( ++
++ Again an unfinished message was sent out because of a wrong key combo - sorry    :( ++

Hello again,

Yesterday I reported about not receiving anything from cell_log:

> <000e> cell_log.c:829 Scanner initialized
> Mobile initialized, please start phone now!
> 
> ...and does not seem to do anything else. osmocom.log is empty, nothing is saved in ~/cell_logger.

Today I compiled also the version of osmocom without burst_ind patch. It works, at least up to messaging between the phone and the host. I noticed that osmocom reports differently with and without burst_ind:

with burst_ind (and not working):
++++++++++++++++++++++++++++++++++++++++++++
Finished, sent 49 blocks in total
Received block ack from phone
Sending checksum: 0x92 
Checksum on phone side matches, let's branch to your code
Branching to 0x00820000
Received branch ack, your code is running now!
++++++++++++++++++++++++++++++++++++++++++++


without burst_ind:
++++++++++++++++++++++++++++++++++++++++++++
Finished, sent 47 blocks in total
Received block ack from phone
Sending checksum: 0xdf 
Checksum on phone side matches, let's branch to your code
Branching to 0x00820000
Received branch ack, your code is running now!


OSMOCOM Layer 1 (revision )
======================================================================
Device ID code: 0xb496
Device Version code: 0x0000
ARM ID code: 0xfff3
cDSP ID code: 0x0128
Die ID code: e5152505e5159b5f
======================================================================
REG_DPLL=0x2413
CNTL_ARM_CLK=0xf0a1
CNTL_CLK=0xff91
CNTL_RST=0xfff3
CNTL_ARM_DIV=0xfff9
======================================================================


THIS FIRMWARE WAS COMPILED WITHOUT TX SUPPORT!!!
Assert DSP into Reset
Releasing DSP from Reset
Setting some dsp_api.ndb values
Setting API NDB parameters
DSP Download Status: 0x0001
DSP API Version: 0x0000 0x0000
Finishing download phase
DSP Download Status: 0x0002
DSP API Version: 0x3606 0x0000
LOST 1086!

++++++++++++++++++++++++++++++++++++++++++++


So, I conclude that the version with burst_ind patch did not actually properly start.
Does this sound plausible?
Anyone else has hit this?
Any hints to investigate further?

Thank you again for your patience...

D.



More information about the Gsmmap mailing list