[Gsmmap] SnoopSnitch: could not init diag IF

Alex Senier alex at srlabs.de
Sun Mar 22 15:44:14 CET 2015


Hi Ralf,

On 21/03/15 19:14, Ralf G. R. Bergs wrote:
> SnoopSnitch used to "work" (AFAICT) on my HTC Desire S/"Saga" running
> CM12. On 2015-01-23 I installed it (so it was probably version 0.9.3).
> It did not complain then that it's incompatible, but seemed to work fine
> (i. e. made test and received test calls and sent/received test SMS).

Note, that the active test is not directly related to the Qualcomm part
of the app. There are Qualcomm devices that do not give us baseband
messages despite the driver exists and the initialization seemingly
worked OK. In 0.9.4 we introduced a check in the active test and in
0.9.5 a warning message in the dashboard if no baseband messages were
received.

> SnoopSnitch 0.9.5 complains as follows:
> 
>     Your device is not compatible. REASON: Could not initialize DIAG
>     interface.
> 
> To make sure that it is not a degradation (or even "improvement") of
> SnoopSnitch I installed 0.9.3 which presumably is the version I tried
> back then, but to no avail. The error message remains the same.

Sounds like an "improvement" in your ROM then ;-P The message is the
most definitive sign that the /dev/diag device node on your phone does
not have the respective driver associated.

To check whether the driver is built into the kernel you can indeed look
under /proc/devices. There should be a character device named "dia". On
my Moto E this yields:

$ grep dia$ /proc/devices
247 dia

The diag device indeed has that major number:

$ ls -l /dev/diag
crw-rw---- system   qcom_diag 247,   0 1970-02-02 03:25 diag

You should check that on your device and create an appropriate device
node if necessary. If your kernel does not have the driver (i.e.
DIAG_CHAR is disabled), you can try building your own CM ROM or kernel
with that driver enabled.

HTH.

Cheers,
Alex

-- 
Security Research Labs



More information about the Gsmmap mailing list