[Gsmmap] SnoopSnitch: could not init diag IF

Ralf G. R. Bergs Ralf+SRLabs at bergs.biz
Mon Mar 23 10:28:54 CET 2015


Hi Alex.

On 2015-03-22 15:44 , Alex Senier wrote:
> Note, that the active test is not directly related to the Qualcomm
> part of the app. There are Qualcomm devices that do not give us
> baseband messages despite the driver exists and the initialization
> seemingly worked OK. In 0.9.4 we introduced a check in the active test
> and in 0.9.5 a warning message in the dashboard if no baseband
> messages were received. 
Good to know. Thanks for shedding some light on this!
>> SnoopSnitch 0.9.5 complains as follows:
>>
>>     Your device is not compatible. REASON: Could not initialize DIAG
>>     interface.
>>
>> To make sure that it is not a degradation (or even "improvement") of
>> SnoopSnitch I installed 0.9.3 which presumably is the version I tried
>> back then, but to no avail. The error message remains the same.
> Sounds like an "improvement" in your ROM then ;-P
Yes, so it seems... ;-)
> To check whether the driver is built into the kernel you can indeed look
> under /proc/devices. There should be a character device named "dia". On
> my Moto E this yields:
>
> $ grep dia$ /proc/devices
> 247 dia
>
> The diag device indeed has that major number:
>
> $ ls -l /dev/diag
> crw-rw---- system   qcom_diag 247,   0 1970-02-02 03:25 diag
>
> You should check that on your device and create an appropriate device
> node if necessary.
I now reverted to an older ROM version, and it seems pretty obvious that
the driver was present there:
> root at saga:/ # ls -la /dev/diag
> crw-rw-rw- root     root     240,   0 2015-03-23 09:55 diag
> root at saga:/ # grep dia$ /proc/devices
> 240 dia
I will let the developer know so that they can look into it. I don't
think re-adding the driver will consume considerable resources, or will it?

Thanks for your help!

Kind regards,

Ralf





More information about the Gsmmap mailing list