[Gsmmap] Snoopsnitch on Galaxy S4

Bogdan Diaconescu b_diaconescu at yahoo.com
Fri Feb 24 13:51:10 CET 2017


Hi guys,
I am trying to use the snoopsnitch app on a Samsung Galaxy S4 phone but when doing active tests the app shows an error saying that no baseband messages are received after making the initial call. And then it quits.
Here is what I've done to prepare the phone:
- I rooted the phone (it has an android 5.0.1 on it). Snoopsnitch finds /dev/diag as it does not complain when it starts.- With *#9900# I set the DEBUG LEVEL ENABLE to HIGH- With *#7264# I see only one entry: UART: with MODEM and PDA options. I tried both with the same results. I don't see an USB entry here though.
- With *#0808# I set for AP: RNDIS+DM+MODEM or DM+MODEM+ADB (same end result for both).
- Put the phone in recovery mode and enabled CP logging.- Enabled developer menu and Set USB debugging (tried with both USB deugging on and off with the same result).
I used the set-up initially to install QPST and QXDM on Windows 7. There are two ports that appear beside the Modem one and eventually QPST sees the phone on the ports and QXDM is able to receive log data. So it works.

I tried also xgoldmon and xgoldscanner (it has USB PID and VID hardcoded though and needs some changes) on Ubuntu and although /dev/ttyACM0 appears in the sytem, nothing is output.
What is the right option for snoopsnitch, I guess no USB debugging needed?
Thanks,Bogdan








-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.srlabs.de/pipermail/gsmmap/attachments/20170224/65062078/attachment.html>


More information about the Gsmmap mailing list