<html><head></head><body><div style="color:#000; background-color:#fff; font-family:HelveticaNeue-Light, Helvetica Neue Light, Helvetica Neue, Helvetica, Arial, Lucida Grande, sans-serif;font-size:16px"><div id="yui_3_16_0_1_1487920504962_70530">Hi guys,</div><div id="yui_3_16_0_1_1487920504962_70741"><br></div><div dir="ltr" id="yui_3_16_0_1_1487920504962_70558">I am trying to use the snoopsnitch app on a Samsung Galaxy S4 phone but when doing active tests the app shows an error saying that no baseband messages are received after making the initial call. And then it quits.</div><div dir="ltr" id="yui_3_16_0_1_1487920504962_70742"><br></div><div dir="ltr" id="yui_3_16_0_1_1487920504962_70656">Here is what I've done to prepare the phone:</div><div dir="ltr" id="yui_3_16_0_1_1487920504962_70756"><br></div><div dir="ltr" id="yui_3_16_0_1_1487920504962_70559">- I rooted the phone (it has an android 5.0.1 on it). Snoopsnitch finds /dev/diag as it does not complain when it starts.</div><div dir="ltr" id="yui_3_16_0_1_1487920504962_70757">- With *#9900# I set the DEBUG LEVEL ENABLE to HIGH</div><div dir="ltr" id="yui_3_16_0_1_1487920504962_70643">- With *#7264# I see only one entry: UART: with MODEM and PDA options. I tried both with the same results. I don't see an USB entry here though.<br></div><div dir="ltr" id="yui_3_16_0_1_1487920504962_70642">- With *#0808# I set for AP: RNDIS+DM+MODEM or DM+MODEM+ADB (same end result for both).<br></div><div dir="ltr" id="yui_3_16_0_1_1487920504962_70560">- Put the phone in recovery mode and enabled CP logging.</div><div dir="ltr" id="yui_3_16_0_1_1487920504962_70641">- Enabled developer menu and Set USB debugging (tried with both USB deugging on and off with the same result).</div><div dir="ltr" id="yui_3_16_0_1_1487920504962_70561"><br></div><div dir="ltr" id="yui_3_16_0_1_1487920504962_70562">I used the set-up initially to install QPST and QXDM on Windows 7. There are two ports that appear beside the Modem one and eventually QPST sees the phone on the ports and QXDM is able to receive log data. So it works.<br></div><div dir="ltr" id="yui_3_16_0_1_1487920504962_70625"><br></div><div dir="ltr" id="yui_3_16_0_1_1487920504962_70781">I tried also xgoldmon and xgoldscanner (it has USB PID and VID hardcoded though and needs some changes) on Ubuntu and although /dev/ttyACM0 appears in the sytem, nothing is output.</div><div dir="ltr" id="yui_3_16_0_1_1487920504962_70797"><br></div><div dir="ltr" id="yui_3_16_0_1_1487920504962_70821">What is the right option for snoopsnitch, I guess no USB debugging needed?</div><div dir="ltr" id="yui_3_16_0_1_1487920504962_70822"><br></div><div dir="ltr" id="yui_3_16_0_1_1487920504962_70819">Thanks,</div><div dir="ltr" id="yui_3_16_0_1_1487920504962_70816">Bogdan<br></div><div dir="ltr" id="yui_3_16_0_1_1487920504962_70779"><br></div><div dir="ltr" id="yui_3_16_0_1_1487920504962_70780"><br></div><div dir="ltr" id="yui_3_16_0_1_1487920504962_70563"><br></div><div dir="ltr" id="yui_3_16_0_1_1487920504962_70564"><br></div><div dir="ltr" id="yui_3_16_0_1_1487920504962_70565"><br></div><div dir="ltr" id="yui_3_16_0_1_1487920504962_70567"><br></div><div dir="ltr" id="yui_3_16_0_1_1487920504962_70566"><br></div><div id="yui_3_16_0_1_1487920504962_70162"><br></div></div></body></html>